Hướng dẫn cấu hình PPPoE trên Router Cisco

0
(0)

Trong Hướng dẫn này giúp các bạn cấu hình FTTH – PPPoE trên thiết bị router Cisco. Ngoài việc cấu hình PPPoE, hướng dẫn này cũng giúp bạn biết cách public 1 dịch vụ từ mạng LAN ra ngoài Internet.

 

Cấu hình PPOE trên Router Cisco

  • Yêu cầu: sử dụng Router Cisco xác thực PPPoE, nhận IP cấp phát từ nhà mạng, các PC trong mạng LAN truy cập được Internet

Chuẩn Bị

  • Thông tin username/password của thuê bao được nhà mạng cung cấp (liên hệ nhà mạng hoặc xem trên hợp đồng)
  • Cắm Converter nếu hoặc cấu hình bridge trên modem của nhà mạng.
  • Xác định cổng WAN (như trên là G0/1) và LAN (G0/0), cắm dây mạng, đồng thời cấu hình Interface cho mạng LAN
  • Mỗi nhà mạng đều sẽ có đánh vlan tag cho cổng nên bạn cần phải set vlan cho cổng WAN, bạn có thể set vlan trong lúc bridge modem hoặc trên router cisco, vì mình muốn quản lý hoàn toàn trên router nên sẽ set trên router (để biết chính xác được nhà mạng mình đang gắn thuê bao của mình vào vlan nào các bạn có thể contact KTV khu vực hoặc gọi hotline, thường mạng Viettel là vlan 35 và VNPT là 11)

Cấu hình PPPoE Trên Router Cisco

  • Cấu hình Interface LAN
CISCO(config)# interface GigabitEthernet0/0
CISCO(config-if)#description #LAN Interface#
CISCO(config-if)#ip address 192.168.1.1
CISCO(config-if)#no shutdown
CISCO(config-if)#ip nat inside
  • Cấu hình Interface WAN
CISCO(config)# interface GigabitEthernet0/1
CISCO(config-if)#description #WAN Interface#
CISCO(config-if)#no ip address
CISCO(config-if)#pppoe enable group global
CISCO(config-if)#pppoe-client dial-pool-number 1
CISCO(config-if)#no shutdown
  • Cấu hình subinterface trên cổng WAN theo vlan nhà mạng (ở đây mình dùng Viettel, vlan 35)
CISCO(config)#interface GigabitEthernet0/2.35
CISCO(config-if)#encapsulation dot1Q 35
CISCO(config-if)#pppoe enable (Cho phép PPPoE trên interface)
CISCO(config-if)#pppoe-client dial-pool-number 1 (Gắn interface dialer)
  • Tạo Dialer Interface dùng để quay PPPoE
CISCO(config)# interface dialer 1
CISCO(config-if)#description #Dialer interface#
CISCO(config-if)#ip mtu 1492
CISCO(config-if)# dialer pool 1
CISCO(config-if)# encapsulation ppp
CISCO(config-if)# ip address negotiated
CISCO(config-if)#ip nat outside
CISCO(config-if)#ppp pap sent-username ftth_myUsername password 0 ftth_myPassword
  • NAT Overload
CISCO(config)#ip nat inside source list 100 interface Dialer1 overload
CISCO(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any
CISCO(config)#ip route 0.0.0.0 0.0.0.0 Dialer 1
  • Nat cổng 80 của webserver 192.168.1.10 ra ngoài ip public thành cổng 80 (tuỳ chọn)
CISCO(config)#ip nat inside source static tcp 192.168.1.100 80 interface Dialer 1 80
  • Bên dưới là các lệnh dùng để troubleshooting cấu hinh PPPoE, NAT và tài liệu tham khảo:
CISCO(config)#show ip interface brief
CISCO(config)#show ip nat translation
CISCO(config)#debug ppp authentication

Bài viết này hữu ích như thế nào?

Hãy bấm vào ngôi sao để đánh giá!

Đánh giá trung bình 0 / 5. Số phiếu bầu: 0

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *